Investigating Service Disruption

Incident Report for Escapia

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 15:45 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 15, 2026 - 14:07 CDT

Monitoring

Service has been restored. Engineers are monitoring.
Posted Jun 15, 2026 - 14:05 CDT

Investigating

We are currently experiencing a service disruption. Resources are engaged to resolve this issue as quickly as possible. We'll post additional updates as we learn more.
Posted Jun 15, 2026 - 11:39 CDT
This incident affected: Third Party Services (Adobe Sign).