Payment Services Degraded

Incident Report for Escapia

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 12:35 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 18, 2025 - 10:46 CDT

Update

Escapia engineering team is continuing to investigate this issue.
Posted Aug 16, 2025 - 17:24 CDT

Update

Escapia engineering team is engaged and continuing to investigate this issue.
Posted Aug 15, 2025 - 16:05 CDT

Investigating

We are currently investigating this issue.
Posted Aug 15, 2025 - 14:17 CDT
This incident affects: Payment Services.