Third Party Degradation - Rental Agreements

Incident Report for Escapia

Resolved

Issue is Resolved, we are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:48 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:47 CDT

Monitoring

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:43 CDT

Investigating

Please be advised that Rental Agreement processing is degraded due to an issue with Adobe. Our team is aware of the problem and is actively monitoring.
Posted Oct 20, 2025 - 14:40 CDT
This incident affected: Escapia® Services (Accounting), Property Management Portals (Automated Payments), Glad To Have You Services (Hospitality), and Third Party Services (Payment Services).