Investigating Service Disruption

Incident Report for Escapia

Resolved

Issue is resolved and service has been fully restored.
Posted Apr 29, 2026 - 16:47 CDT

Monitoring

Service has been restored. Engineers are monitoring.
Posted Apr 29, 2026 - 14:24 CDT

Investigating

We are currently experiencing a service disruption. Resources are engaged to resolve this issue as quickly as possible. We'll post additional updates as we learn more.
Posted Apr 29, 2026 - 12:31 CDT
This incident affected: Escapia® Services (Login).