Payment Service Degraded

Incident Report for Escapia

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 20:49 CST

Update

We are continuing to work on a fix for this issue.
Posted Nov 29, 2023 - 18:49 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 29, 2023 - 17:14 CST

Update

We are continuing to investigate this issue.
Posted Nov 29, 2023 - 16:13 CST

Update

We are continuing to investigate this issue.
Posted Nov 29, 2023 - 14:31 CST

Investigating

We are currently investigating this issue.
Posted Nov 29, 2023 - 13:02 CST
This incident affected: Payment Services.